package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+?56){0,1}(9)[98765]\d{7}$`)
var str = `+56932165481
965432189
+56986549874
+56965487d+ 56 9
+56 9 87135689
+569 8765321
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}