const regex = new RegExp('^(\\+?56){0,1}(9)[98765]\\d{7}$', 'gm')
const str = `+56932165481
965432189
+56986549874
+56965487d+ 56 9
+56 9 87135689
+569 8765321
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}