using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+?56){0,1}(9)[98765]\d{7}$";
string input = @"+56932165481
965432189
+56986549874
+56965487d+ 56 9
+56 9 87135689
+569 8765321
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}