#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+?56){0,1}(9)[98765]\d{7}$"
Local $sString = "+56932165481" & @CRLF & _
"965432189" & @CRLF & _
"+56986549874" & @CRLF & _
"+56965487d+ 56 9" & @CRLF & _
"+56 9 87135689" & @CRLF & _
"+569 8765321" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")