use strict;
my $str = '+56932165481
965432189
+56986549874
+56965487d+ 56 9
+56 9 87135689
+569 8765321
';
my $regex = qr/^(\+?56){0,1}(9)[98765]\d{7}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}