import Foundation
let pattern = #"([371|+371]?\d+|[^\s\@]+\@\w+\.\w{2,4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
+3712964443
29643442
JEVGENIJS@gmail.COM
jevgenijs.blaus@orocon.me
hsjdm.jsjdj.kdmdks
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)