import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([371|+371]?\\d+|[^\\s\\@]+\\@\\w+\\.\\w{2,4})";
final String string = "+3712964443\n"
+ "29643442\n"
+ "JEVGENIJS@gmail.COM\n"
+ "jevgenijs.blaus@orocon.me\n"
+ "hsjdm.jsjdj.kdmdks";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}