#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([371|+371]?\d+|[^\s\@]+\@\w+\.\w{2,4})"
Local $sString = "+3712964443" & @CRLF & _
"29643442" & @CRLF & _
"JEVGENIJS@gmail.COM" & @CRLF & _
"jevgenijs.blaus@orocon.me" & @CRLF & _
"hsjdm.jsjdj.kdmdks"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")