package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([371|+371]?\d+|[^\s\@]+\@\w+\.\w{2,4})`)
var str = `+3712964443
29643442
JEVGENIJS@gmail.COM
jevgenijs.blaus@orocon.me
hsjdm.jsjdj.kdmdks`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}