re = /([371|+371]?\d+|[^\s\@]+\@\w+\.\w{2,4})/
str = '+3712964443
29643442
JEVGENIJS@gmail.COM
jevgenijs.blaus@orocon.me
hsjdm.jsjdj.kdmdks'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end