const regex = /([371|+371]?\d+|[^\s\@]+\@\w+\.\w{2,4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([371|+371]?\\d+|[^\\s\\@]+\\@\\w+\\.\\w{2,4})', 'g')
const str = `+3712964443
29643442
JEVGENIJS@gmail.COM
jevgenijs.blaus@orocon.me
hsjdm.jsjdj.kdmdks`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}