// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([371|+371]?\d+|[^\s\@]+\@\w+\.\w{2,4})").unwrap();
let string = "+3712964443
29643442
JEVGENIJS@gmail.COM
jevgenijs.blaus@orocon.me
hsjdm.jsjdj.kdmdks";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}