import Foundation
let pattern = #"^\[(?P<timestamp>(\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}\.\d{3}[\+\-]\d{2}:\d{2}|\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}))\](?:\[(?<logLevel>[^\]]+)\])*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[2006/01/02 15:04:05.000-07:00] lorem ipsum
[2006/01/02 15:04:05] dolorem doipsum
[2006/01/02 15:04:05.000+01:00] abrakadabra
[2006/01/02 15:04:05] eresh piklosh nemeshchi hunyad sczepenh kamosh
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)