$re = '/^\[(?P<timestamp>(\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}\.\d{3}[\+\-]\d{2}:\d{2}|\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}))\](?:\[(?<logLevel>[^\]]+)\])*/m';
$str = '[2006/01/02 15:04:05.000-07:00] lorem ipsum
[2006/01/02 15:04:05] dolorem doipsum
[2006/01/02 15:04:05.000+01:00] abrakadabra
[2006/01/02 15:04:05] eresh piklosh nemeshchi hunyad sczepenh kamosh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);