#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[(?P<timestamp>(\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}\.\d{3}[\+\-]\d{2}:\d{2}|\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}))\](?:\[(?<logLevel>[^\]]+)\])*"
Local $sString = "[2006/01/02 15:04:05.000-07:00] lorem ipsum" & @CRLF & _
"[2006/01/02 15:04:05] dolorem doipsum" & @CRLF & _
"[2006/01/02 15:04:05.000+01:00] abrakadabra" & @CRLF & _
"[2006/01/02 15:04:05] eresh piklosh nemeshchi hunyad sczepenh kamosh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")