const regex = /^\[(?P<timestamp>(\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}\.\d{3}[\+\-]\d{2}:\d{2}|\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}))\](?:\[(?<logLevel>[^\]]+)\])*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[(?P<timestamp>(\\d{4}\\\/\\d{2}\\\/\\d{2}\\s+\\d{2}:\\d{2}:\\d{2}\\.\\d{3}[\\+\\-]\\d{2}:\\d{2}|\\d{4}\\\/\\d{2}\\\/\\d{2}\\s+\\d{2}:\\d{2}:\\d{2}))\\](?:\\[(?<logLevel>[^\\]]+)\\])*', 'gm')
const str = `[2006/01/02 15:04:05.000-07:00] lorem ipsum
[2006/01/02 15:04:05] dolorem doipsum
[2006/01/02 15:04:05.000+01:00] abrakadabra
[2006/01/02 15:04:05] eresh piklosh nemeshchi hunyad sczepenh kamosh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}