import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[(?P<timestamp>(\\d{4}\\/\\d{2}\\/\\d{2}\\s+\\d{2}:\\d{2}:\\d{2}\\.\\d{3}[\\+\\-]\\d{2}:\\d{2}|\\d{4}\\/\\d{2}\\/\\d{2}\\s+\\d{2}:\\d{2}:\\d{2}))\\](?:\\[(?<logLevel>[^\\]]+)\\])*";
final String string = "[2006/01/02 15:04:05.000-07:00] lorem ipsum\n"
+ "[2006/01/02 15:04:05] dolorem doipsum\n"
+ "[2006/01/02 15:04:05.000+01:00] abrakadabra\n"
+ "[2006/01/02 15:04:05] eresh piklosh nemeshchi hunyad sczepenh kamosh";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}