// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[(?P<timestamp>(\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}\.\d{3}[\+\-]\d{2}:\d{2}|\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}))\](?:\[(?<logLevel>[^\]]+)\])*").unwrap();
let string = "[2006/01/02 15:04:05.000-07:00] lorem ipsum
[2006/01/02 15:04:05] dolorem doipsum
[2006/01/02 15:04:05.000+01:00] abrakadabra
[2006/01/02 15:04:05] eresh piklosh nemeshchi hunyad sczepenh kamosh";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}