using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[(?P<timestamp>(\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}\.\d{3}[\+\-]\d{2}:\d{2}|\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}))\](?:\[(?<logLevel>[^\]]+)\])*";
string input = @"[2006/01/02 15:04:05.000-07:00] lorem ipsum
[2006/01/02 15:04:05] dolorem doipsum
[2006/01/02 15:04:05.000+01:00] abrakadabra
[2006/01/02 15:04:05] eresh piklosh nemeshchi hunyad sczepenh kamosh";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}