// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:\/\*.*\*\/)?.*\(')?({.*})('\))?").unwrap();
let string = "('{ \"common\": { \"isYandex\": \"0\", \"canRetry\": 0, \"isYandexPage\": \"0\", \"reloadTimeout\": \"30\" }, \"rtbAuctionInfo\": { \"deal\": {}, \"dspId\": 10, \"winPrice\": 0, \"auctionSchedule\": [] } }')
/**/('{ \"common\": { \"isYandex\": \"0\", \"canRetry\": 0, \"isYandexPage\": \"0\", \"reloadTimeout\": \"30\" }, \"rtbAuctionInfo\": { \"deal\": {}, \"dspId\": 10, \"winPrice\": 0, \"auctionSchedule\": [] } }')
/*{helo}*/helo('{ \"common\": { \"isYandex\": \"0\", \"canRetry\": 0, \"isYandexPage\": \"0\", \"reloadTimeout\": \"30\" }, \"rtbAuctionInfo\": { \"deal\": {}, \"dspId\": 10, \"winPrice\": 0, \"auctionSchedule\": [] } }')
/*{helo}*/helo('{ }')
/**/Ya[5248222852932]('{\"direct\":{\"ads\":[{\"domain\"}')
{\"direct\":{\"ads\":[{\"domain\"}
skdE[9835757330451]('{\"direct\":{\"ads\":[{\"domain\"}')";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}