using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\/\*.*\*\/)?.*\(')?({.*})('\))?";
string input = @"('{ ""common"": { ""isYandex"": ""0"", ""canRetry"": 0, ""isYandexPage"": ""0"", ""reloadTimeout"": ""30"" }, ""rtbAuctionInfo"": { ""deal"": {}, ""dspId"": 10, ""winPrice"": 0, ""auctionSchedule"": [] } }')
/**/('{ ""common"": { ""isYandex"": ""0"", ""canRetry"": 0, ""isYandexPage"": ""0"", ""reloadTimeout"": ""30"" }, ""rtbAuctionInfo"": { ""deal"": {}, ""dspId"": 10, ""winPrice"": 0, ""auctionSchedule"": [] } }')
/*{helo}*/helo('{ ""common"": { ""isYandex"": ""0"", ""canRetry"": 0, ""isYandexPage"": ""0"", ""reloadTimeout"": ""30"" }, ""rtbAuctionInfo"": { ""deal"": {}, ""dspId"": 10, ""winPrice"": 0, ""auctionSchedule"": [] } }')
/*{helo}*/helo('{ }')
/**/Ya[5248222852932]('{""direct"":{""ads"":[{""domain""}')
{""direct"":{""ads"":[{""domain""}
skdE[9835757330451]('{""direct"":{""ads"":[{""domain""}')";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}