import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\/\\*.*\\*\\/)?.*\\(')?(\\{.*\\})('\\))?";
final String string = "('{ \"common\": { \"isYandex\": \"0\", \"canRetry\": 0, \"isYandexPage\": \"0\", \"reloadTimeout\": \"30\" }, \"rtbAuctionInfo\": { \"deal\": {}, \"dspId\": 10, \"winPrice\": 0, \"auctionSchedule\": [] } }')\n"
+ "/**/('{ \"common\": { \"isYandex\": \"0\", \"canRetry\": 0, \"isYandexPage\": \"0\", \"reloadTimeout\": \"30\" }, \"rtbAuctionInfo\": { \"deal\": {}, \"dspId\": 10, \"winPrice\": 0, \"auctionSchedule\": [] } }')\n"
+ "/*{helo}*/helo('{ \"common\": { \"isYandex\": \"0\", \"canRetry\": 0, \"isYandexPage\": \"0\", \"reloadTimeout\": \"30\" }, \"rtbAuctionInfo\": { \"deal\": {}, \"dspId\": 10, \"winPrice\": 0, \"auctionSchedule\": [] } }')\n"
+ "/*{helo}*/helo('{ }')\n"
+ "/**/Ya[5248222852932]('{\"direct\":{\"ads\":[{\"domain\"}')\n"
+ "{\"direct\":{\"ads\":[{\"domain\"}\n"
+ "skdE[9835757330451]('{\"direct\":{\"ads\":[{\"domain\"}')";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}