use strict;
my $str = '(\'{ "common": { "isYandex": "0", "canRetry": 0, "isYandexPage": "0", "reloadTimeout": "30" }, "rtbAuctionInfo": { "deal": {}, "dspId": 10, "winPrice": 0, "auctionSchedule": [] } }\')
/**/(\'{ "common": { "isYandex": "0", "canRetry": 0, "isYandexPage": "0", "reloadTimeout": "30" }, "rtbAuctionInfo": { "deal": {}, "dspId": 10, "winPrice": 0, "auctionSchedule": [] } }\')
/*{helo}*/helo(\'{ "common": { "isYandex": "0", "canRetry": 0, "isYandexPage": "0", "reloadTimeout": "30" }, "rtbAuctionInfo": { "deal": {}, "dspId": 10, "winPrice": 0, "auctionSchedule": [] } }\')
/*{helo}*/helo(\'{ }\')
/**/Ya[5248222852932](\'{"direct":{"ads":[{"domain"}\')
{"direct":{"ads":[{"domain"}
skdE[9835757330451](\'{"direct":{"ads":[{"domain"}\')';
my $regex = qr/((?:\/\*.*\*\/)?.*\(')?({.*})('\))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}