# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:\/\*.*\*\/)?.*\(')?({.*})('\))?"
test_str = ("('{ \"common\": { \"isYandex\": \"0\", \"canRetry\": 0, \"isYandexPage\": \"0\", \"reloadTimeout\": \"30\" }, \"rtbAuctionInfo\": { \"deal\": {}, \"dspId\": 10, \"winPrice\": 0, \"auctionSchedule\": [] } }')\n"
"/**/('{ \"common\": { \"isYandex\": \"0\", \"canRetry\": 0, \"isYandexPage\": \"0\", \"reloadTimeout\": \"30\" }, \"rtbAuctionInfo\": { \"deal\": {}, \"dspId\": 10, \"winPrice\": 0, \"auctionSchedule\": [] } }')\n"
"/*{helo}*/helo('{ \"common\": { \"isYandex\": \"0\", \"canRetry\": 0, \"isYandexPage\": \"0\", \"reloadTimeout\": \"30\" }, \"rtbAuctionInfo\": { \"deal\": {}, \"dspId\": 10, \"winPrice\": 0, \"auctionSchedule\": [] } }')\n"
"/*{helo}*/helo('{ }')\n"
"/**/Ya[5248222852932]('{\"direct\":{\"ads\":[{\"domain\"}')\n"
"{\"direct\":{\"ads\":[{\"domain\"}\n"
"skdE[9835757330451]('{\"direct\":{\"ads\":[{\"domain\"}')")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.