re = /((?:\/\*.*\*\/)?.*\(')?({.*})('\))?/m
str = '(\'{ "common": { "isYandex": "0", "canRetry": 0, "isYandexPage": "0", "reloadTimeout": "30" }, "rtbAuctionInfo": { "deal": {}, "dspId": 10, "winPrice": 0, "auctionSchedule": [] } }\')
/**/(\'{ "common": { "isYandex": "0", "canRetry": 0, "isYandexPage": "0", "reloadTimeout": "30" }, "rtbAuctionInfo": { "deal": {}, "dspId": 10, "winPrice": 0, "auctionSchedule": [] } }\')
/*{helo}*/helo(\'{ "common": { "isYandex": "0", "canRetry": 0, "isYandexPage": "0", "reloadTimeout": "30" }, "rtbAuctionInfo": { "deal": {}, "dspId": 10, "winPrice": 0, "auctionSchedule": [] } }\')
/*{helo}*/helo(\'{ }\')
/**/Ya[5248222852932](\'{"direct":{"ads":[{"domain"}\')
{"direct":{"ads":[{"domain"}
skdE[9835757330451](\'{"direct":{"ads":[{"domain"}\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end