#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:\/\*.*\*\/)?.*\(')?({.*})('\))?"
Local $sString = "('{ "common": { "isYandex": "0", "canRetry": 0, "isYandexPage": "0", "reloadTimeout": "30" }, "rtbAuctionInfo": { "deal": {}, "dspId": 10, "winPrice": 0, "auctionSchedule": [] } }')" & @CRLF & _
"/**/('{ "common": { "isYandex": "0", "canRetry": 0, "isYandexPage": "0", "reloadTimeout": "30" }, "rtbAuctionInfo": { "deal": {}, "dspId": 10, "winPrice": 0, "auctionSchedule": [] } }')" & @CRLF & _
"/*{helo}*/helo('{ "common": { "isYandex": "0", "canRetry": 0, "isYandexPage": "0", "reloadTimeout": "30" }, "rtbAuctionInfo": { "deal": {}, "dspId": 10, "winPrice": 0, "auctionSchedule": [] } }')" & @CRLF & _
"/*{helo}*/helo('{ }')" & @CRLF & _
"/**/Ya[5248222852932]('{"direct":{"ads":[{"domain"}')" & @CRLF & _
"{"direct":{"ads":[{"domain"}" & @CRLF & _
"skdE[9835757330451]('{"direct":{"ads":[{"domain"}')"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")