import Foundation
let pattern = #"const r = new WillyRouter\(\);([\s\S]*?)Vue.use\(VueRouter\);"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
import { routerConfig } from '@portaal/routes/global.js';
import WillyRouter from '@portaal/router.js';
import routesKwaliteitsdocumenten from './routes/kwaliteitsdocumenten.js';
import routesKennisbank from './routes/kennisbank.js';
import routesWiki from './routes/wiki.js';
const r = new WillyRouter();
// Custom routes toevoegen, verwijderen etc
r.add('custom_dms', routesKwaliteitsdocumenten);
r.add('custom_wiki', routesWiki);
r.add('custom_kennisbank', routesKennisbank);
// r.changeByName('groep.informatie', {
// component: CustomComponent,
// });
// r.removeByName('beeldbank-beelden-beeldbankClienten');
Vue.use(VueRouter);
const router = new VueRouter({
...routerConfig,
routes: r.getAll(),
});
export default router;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}