package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`const r = new WillyRouter\(\);([\s\S]*?)Vue.use\(VueRouter\);`)
var str = `import { routerConfig } from '@portaal/routes/global.js';
import WillyRouter from '@portaal/router.js';
import routesKwaliteitsdocumenten from './routes/kwaliteitsdocumenten.js';
import routesKennisbank from './routes/kennisbank.js';
import routesWiki from './routes/wiki.js';
const r = new WillyRouter();
// Custom routes toevoegen, verwijderen etc
r.add('custom_dms', routesKwaliteitsdocumenten);
r.add('custom_wiki', routesWiki);
r.add('custom_kennisbank', routesKennisbank);
// r.changeByName('groep.informatie', {
// component: CustomComponent,
// });
// r.removeByName('beeldbank-beelden-beeldbankClienten');
Vue.use(VueRouter);
const router = new VueRouter({
...routerConfig,
routes: r.getAll(),
});
export default router;
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}