use strict;
my $str = 'import { routerConfig } from \'@portaal/routes/global.js\';
import WillyRouter from \'@portaal/router.js\';
import routesKwaliteitsdocumenten from \'./routes/kwaliteitsdocumenten.js\';
import routesKennisbank from \'./routes/kennisbank.js\';
import routesWiki from \'./routes/wiki.js\';
const r = new WillyRouter();
// Custom routes toevoegen, verwijderen etc
r.add(\'custom_dms\', routesKwaliteitsdocumenten);
r.add(\'custom_wiki\', routesWiki);
r.add(\'custom_kennisbank\', routesKennisbank);
// r.changeByName(\'groep.informatie\', {
// component: CustomComponent,
// });
// r.removeByName(\'beeldbank-beelden-beeldbankClienten\');
Vue.use(VueRouter);
const router = new VueRouter({
...routerConfig,
routes: r.getAll(),
});
export default router;
';
my $regex = qr/const r = new WillyRouter\(\);([\s\S]*?)Vue.use\(VueRouter\);/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}