// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"const r = new WillyRouter\(\);([\s\S]*?)Vue.use\(VueRouter\);").unwrap();
let string = "import { routerConfig } from '@portaal/routes/global.js';
import WillyRouter from '@portaal/router.js';
import routesKwaliteitsdocumenten from './routes/kwaliteitsdocumenten.js';
import routesKennisbank from './routes/kennisbank.js';
import routesWiki from './routes/wiki.js';
const r = new WillyRouter();
// Custom routes toevoegen, verwijderen etc
r.add('custom_dms', routesKwaliteitsdocumenten);
r.add('custom_wiki', routesWiki);
r.add('custom_kennisbank', routesKennisbank);
// r.changeByName('groep.informatie', {
// component: CustomComponent,
// });
// r.removeByName('beeldbank-beelden-beeldbankClienten');
Vue.use(VueRouter);
const router = new VueRouter({
...routerConfig,
routes: r.getAll(),
});
export default router;
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}