using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"const r = new WillyRouter\(\);([\s\S]*?)Vue.use\(VueRouter\);";
string input = @"import { routerConfig } from '@portaal/routes/global.js';
import WillyRouter from '@portaal/router.js';
import routesKwaliteitsdocumenten from './routes/kwaliteitsdocumenten.js';
import routesKennisbank from './routes/kennisbank.js';
import routesWiki from './routes/wiki.js';
const r = new WillyRouter();
// Custom routes toevoegen, verwijderen etc
r.add('custom_dms', routesKwaliteitsdocumenten);
r.add('custom_wiki', routesWiki);
r.add('custom_kennisbank', routesKennisbank);
// r.changeByName('groep.informatie', {
// component: CustomComponent,
// });
// r.removeByName('beeldbank-beelden-beeldbankClienten');
Vue.use(VueRouter);
const router = new VueRouter({
...routerConfig,
routes: r.getAll(),
});
export default router;
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}