const regex = /const r = new WillyRouter\(\);([\s\S]*?)Vue.use\(VueRouter\);/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('const r = new WillyRouter\\(\\);([\\s\\S]*?)Vue.use\\(VueRouter\\);', '')
const str = `import { routerConfig } from '@portaal/routes/global.js';
import WillyRouter from '@portaal/router.js';
import routesKwaliteitsdocumenten from './routes/kwaliteitsdocumenten.js';
import routesKennisbank from './routes/kennisbank.js';
import routesWiki from './routes/wiki.js';
const r = new WillyRouter();
// Custom routes toevoegen, verwijderen etc
r.add('custom_dms', routesKwaliteitsdocumenten);
r.add('custom_wiki', routesWiki);
r.add('custom_kennisbank', routesKennisbank);
// r.changeByName('groep.informatie', {
// component: CustomComponent,
// });
// r.removeByName('beeldbank-beelden-beeldbankClienten');
Vue.use(VueRouter);
const router = new VueRouter({
...routerConfig,
routes: r.getAll(),
});
export default router;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}