import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "const r = new WillyRouter\\(\\);([\\s\\S]*?)Vue.use\\(VueRouter\\);";
final String string = "import { routerConfig } from '@portaal/routes/global.js';\n"
+ "import WillyRouter from '@portaal/router.js';\n\n"
+ "import routesKwaliteitsdocumenten from './routes/kwaliteitsdocumenten.js';\n"
+ "import routesKennisbank from './routes/kennisbank.js';\n"
+ "import routesWiki from './routes/wiki.js';\n\n"
+ "const r = new WillyRouter();\n\n"
+ "// Custom routes toevoegen, verwijderen etc\n"
+ "r.add('custom_dms', routesKwaliteitsdocumenten);\n"
+ "r.add('custom_wiki', routesWiki);\n"
+ "r.add('custom_kennisbank', routesKennisbank);\n"
+ "// r.changeByName('groep.informatie', {\n"
+ "// component: CustomComponent,\n"
+ "// });\n"
+ "// r.removeByName('beeldbank-beelden-beeldbankClienten');\n\n"
+ "Vue.use(VueRouter);\n\n"
+ "const router = new VueRouter({\n"
+ " ...routerConfig,\n"
+ " routes: r.getAll(),\n"
+ "});\n\n"
+ "export default router;\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}