re = /Team{name='([a-zA-Z0-9]+)', color=Color:\[rgb(0x[a-zA-Z0-9]+)\], members=\[()\]}/
str = 'Team{name=\'PAO\', color=Color:[rgb0xFF00], members=[]},Team{name=\'RrED\', color=Color:[rgb0x00FF], members=[]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end