$re = '/Team{name=\'([a-zA-Z0-9]+)\', color=Color:\[rgb(0x[a-zA-Z0-9]+)\], members=\[()\]}/';
$str = 'Team{name=\'PAO\', color=Color:[rgb0xFF00], members=[]},Team{name=\'RrED\', color=Color:[rgb0x00FF], members=[]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);