use strict;
my $str = 'Team{name=\'PAO\', color=Color:[rgb0xFF00], members=[]},Team{name=\'RrED\', color=Color:[rgb0x00FF], members=[]}';
my $regex = qr/Team{name='([a-zA-Z0-9]+)', color=Color:\[rgb(0x[a-zA-Z0-9]+)\], members=\[()\]}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}