const regex = /Team{name='([a-zA-Z0-9]+)', color=Color:\[rgb(0x[a-zA-Z0-9]+)\], members=\[()\]}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Team{name=\'([a-zA-Z0-9]+)\', color=Color:\\[rgb(0x[a-zA-Z0-9]+)\\], members=\\[()\\]}', 'g')
const str = `Team{name='PAO', color=Color:[rgb0xFF00], members=[]},Team{name='RrED', color=Color:[rgb0x00FF], members=[]}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}