package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Team{name='([a-zA-Z0-9]+)', color=Color:\[rgb(0x[a-zA-Z0-9]+)\], members=\[()\]}`)
var str = `Team{name='PAO', color=Color:[rgb0xFF00], members=[]},Team{name='RrED', color=Color:[rgb0x00FF], members=[]}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}