using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Team{name='([a-zA-Z0-9]+)', color=Color:\[rgb(0x[a-zA-Z0-9]+)\], members=\[()\]}";
string input = @"Team{name='PAO', color=Color:[rgb0xFF00], members=[]},Team{name='RrED', color=Color:[rgb0x00FF], members=[]}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}