import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Team\\{name='([a-zA-Z0-9]+)', color=Color:\\[rgb(0x[a-zA-Z0-9]+)\\], members=\\[()\\]\\}";
final String string = "Team{name='PAO', color=Color:[rgb0xFF00], members=[]},Team{name='RrED', color=Color:[rgb0x00FF], members=[]}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}