import Foundation
let pattern = #"(?<!\w)(?<!\/\/ )(End ?Function|Next|EndIf|End ?Method)[ \t]*;"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
End Function ;
EndFunction ;
EndMethod ;
Next;
EndIf;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"} // $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)