re = /(?<!\w)(?<!\/\/ )(End ?Function|Next|EndIf|End ?Method)[ \t]*;/m
str = 'End Function ;
EndFunction ;
EndMethod ;
Next;
EndIf; '
subst = '} // $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result