$re = '/(?<!\w)(?<!\/\/ )(End ?Function|Next|EndIf|End ?Method)[ \t]*;/m';
$str = 'End Function ;
EndFunction ;
EndMethod ;
Next;
EndIf; ';
$subst = "} // $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;