#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\w)(?<!\/\/ )(End ?Function|Next|EndIf|End ?Method)[ \t]*;"
Local $sString = "End Function ;" & @CRLF & _
"EndFunction ;" & @CRLF & _
"EndMethod ;" & @CRLF & _
"Next;" & @CRLF & _
"EndIf; "
Local $sSubst = "} // $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)