const regex = /(?<!\w)(?<!\/\/ )(End ?Function|Next|EndIf|End ?Method)[ \t]*;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\w)(?<!\\\/\\\/ )(End ?Function|Next|EndIf|End ?Method)[ \\t]*;', 'gm')
const str = `End Function ;
EndFunction ;
EndMethod ;
Next;
EndIf; `;
const subst = `} // $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);