# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\w)(?<!\\/\\/ )(End ?Function|Next|EndIf|End ?Method)[ \t]*;/} \/\/ $1/gm;t' <<< "End Function ;
EndFunction ;
EndMethod ;
Next;
EndIf; "