use strict;
my $str = 'End Function ;
EndFunction ;
EndMethod ;
Next;
EndIf; ';
my $regex = qr/(?<!\w)(?<!\/\/ )(End ?Function|Next|EndIf|End ?Method)[ \t]*;/mp;
my $subst = '} // $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";