import Foundation
let pattern = #"style=\"\s?.*?text-align:\s?(.*?);?\"|style=\'\s?.*?text-align:\s?(.*?);?\'"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
style="text-align: right"
style='text-align: right'
style='text-align: right"
style="text-align: right'
style="text-align:right"
style='text-align:right'
style="text-align: right;"
style='text-align: right;'
style='text-align: right;"
style="text-align: right;'
style="text-align:right;"
style='text-align:right;'
style="display: block; text-align: right"
style='display: block; text-align: right'
style='display: block; text-align: right"
style="display: block; text-align: right'
style="display: block; text-align:right"
style='display: block; text-align:right'
style="display: block; text-align: right;"
style='display: block; text-align: right;'
style='display: block; text-align: right;"
style="display: block; text-align: right;'
style="display: block; text-align:right;"
style='display: block; text-align:right;'
style="display: block;text-align: right"
style='display: block;text-align: right'
style='display: block;text-align: right"
style="display: block;text-align: right'
style="display: block;text-align:right"
style='display: block;text-align:right'
style="display: block;text-align: right;"
style='display: block;text-align: right;'
style='display: block;text-align: right;"
style="display: block;text-align: right;'
style="display: block;text-align:right;"
style='display: block;text-align:right;'
style="display:block;text-align: right"
style='display:block;text-align: right'
style='display:block;text-align: right"
style="display:block;text-align: right'
style="display:block;text-align:right"
style='display:block;text-align:right'
style="display:block;text-align: right;"
style='display:block;text-align: right;'
style='display:block;text-align: right;"
style="display:block;text-align: right;'
style="display:block;text-align:right;"
style='display:block;text-align:right;'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)