package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)style=\"\s?.*?text-align:\s?(.*?);?\"|style=\'\s?.*?text-align:\s?(.*?);?\'`)
var str = `style="text-align: right"
style='text-align: right'
style='text-align: right"
style="text-align: right'
style="text-align:right"
style='text-align:right'
style="text-align: right;"
style='text-align: right;'
style='text-align: right;"
style="text-align: right;'
style="text-align:right;"
style='text-align:right;'
style="display: block; text-align: right"
style='display: block; text-align: right'
style='display: block; text-align: right"
style="display: block; text-align: right'
style="display: block; text-align:right"
style='display: block; text-align:right'
style="display: block; text-align: right;"
style='display: block; text-align: right;'
style='display: block; text-align: right;"
style="display: block; text-align: right;'
style="display: block; text-align:right;"
style='display: block; text-align:right;'
style="display: block;text-align: right"
style='display: block;text-align: right'
style='display: block;text-align: right"
style="display: block;text-align: right'
style="display: block;text-align:right"
style='display: block;text-align:right'
style="display: block;text-align: right;"
style='display: block;text-align: right;'
style='display: block;text-align: right;"
style="display: block;text-align: right;'
style="display: block;text-align:right;"
style='display: block;text-align:right;'
style="display:block;text-align: right"
style='display:block;text-align: right'
style='display:block;text-align: right"
style="display:block;text-align: right'
style="display:block;text-align:right"
style='display:block;text-align:right'
style="display:block;text-align: right;"
style='display:block;text-align: right;'
style='display:block;text-align: right;"
style="display:block;text-align: right;'
style="display:block;text-align:right;"
style='display:block;text-align:right;'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}