$re = '/style=\"\s?.*?text-align:\s?(.*?);?\"|style=\'\s?.*?text-align:\s?(.*?);?\'/i';
$str = 'style="text-align: right"
style=\'text-align: right\'
style=\'text-align: right"
style="text-align: right\'
style="text-align:right"
style=\'text-align:right\'
style="text-align: right;"
style=\'text-align: right;\'
style=\'text-align: right;"
style="text-align: right;\'
style="text-align:right;"
style=\'text-align:right;\'
style="display: block; text-align: right"
style=\'display: block; text-align: right\'
style=\'display: block; text-align: right"
style="display: block; text-align: right\'
style="display: block; text-align:right"
style=\'display: block; text-align:right\'
style="display: block; text-align: right;"
style=\'display: block; text-align: right;\'
style=\'display: block; text-align: right;"
style="display: block; text-align: right;\'
style="display: block; text-align:right;"
style=\'display: block; text-align:right;\'
style="display: block;text-align: right"
style=\'display: block;text-align: right\'
style=\'display: block;text-align: right"
style="display: block;text-align: right\'
style="display: block;text-align:right"
style=\'display: block;text-align:right\'
style="display: block;text-align: right;"
style=\'display: block;text-align: right;\'
style=\'display: block;text-align: right;"
style="display: block;text-align: right;\'
style="display: block;text-align:right;"
style=\'display: block;text-align:right;\'
style="display:block;text-align: right"
style=\'display:block;text-align: right\'
style=\'display:block;text-align: right"
style="display:block;text-align: right\'
style="display:block;text-align:right"
style=\'display:block;text-align:right\'
style="display:block;text-align: right;"
style=\'display:block;text-align: right;\'
style=\'display:block;text-align: right;"
style="display:block;text-align: right;\'
style="display:block;text-align:right;"
style=\'display:block;text-align:right;\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);